四博智联产品售后

 找回密码
 立即注册
搜索
查看: 7138|回复: 5

Openwrt中wan与lan接口说明

[复制链接]

237

主题

286

帖子

1675

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1675
发表于 2015-6-8 22:42:15 | 显示全部楼层 |阅读模式
简单来说你就把eth0.1 eth0.2当成不同的eth0和eth1啥的,也就是pc上不同的网卡


复杂点说的话,其实那个tplink上只有一个网卡eth0

但他用virtual lan把那个网卡虚拟成两个

其中.1就是对用那个四个lan口
.2对应那个wan口

无线是用桥接的方式连到lan上的

因为是无线,所以他的接口是可以用软件生成的
回复

使用道具 举报

237

主题

286

帖子

1675

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1675
 楼主| 发表于 2015-6-8 22:46:41 | 显示全部楼层


实现功能: 无线连接上级路由器, 然后再通过本机路由器实现有线和无线都能上网.

一. Web界面的操作如下, 很简单的

1、网络->无线, 点击“扫描”按钮。

2、在新出现的界面中,点击你需要中继的网络右边的“加入网络”

3、在新出现的界面中,只在第2行中输入密码, 其余不要改动, 然后点击"提交"

4、再点击“无线”,出现新界面后,点击图中“新增”图标

5、设置你期望的Essid(按照703N的官方说明书, 和上级路由的SSID相同为中继模式, 和上级路由的SSID不相同则为桥接模式),Mode必须设置为Access Point---接入点,NetWork设置为Lan。在Security页面可以设置密码, Channel不能选择和上级路由器的同段., 点击“保存 & 应用”,稍等片刻,应该可以看到wifi信号了, 但一般此时无法连接, 可重启路由器后正常.


二. 配置文件如下, 我一般是用Winscp直接拷贝到 /etc/config 目录下, 然后重启路由就可以了.

----- network 内容如下 ----------
#Repeater: RJ45-->LAN, WIFI-->LAN. 实现有线和无线都可以上网
#电脑端若设置固定IP, 则其DNS为本级路由IP而不能为上级路由的IP

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.2.1' #和上级路由IP不在同段内,我的上级路由为192.168.8.1
option netmask '255.255.255.0'

config interface 'wwan'
option macaddr '00:16:d3:95:55:30'
option proto 'dhcp'        #测试DHCP是稳定的, 但若为静态IP不稳定?

------------ wirelss 的内容如下
#Repeater: RJ45-->LAN, WIFI-->LAN. 实现有线和无线都可以上网

config wifi-device 'radio0'
option type 'mac80211'
option macaddr '38:83:45:36:0c:f0'
option hwmode '11ng'
option htmode 'HT20' #改成'HT40-'则无法上网
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '10'
option txpower '17'
option country 'US'

config wifi-iface
option ssid 'yuanzhi' #上级路由的SSID
option encryption 'psk2' #上级路由的无线密码方式
option device 'radio0'
option mode 'sta'
option network 'wwan'
option key '12345678' #上级路由的无线密码

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'qiushui_007' #本机路由的无线SSID
option encryption 'psk2'
option key '12345678' #本机路由的无线密码
option network 'lan'
回复 支持 反对

使用道具 举报

237

主题

286

帖子

1675

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1675
 楼主| 发表于 2015-6-8 22:48:58 | 显示全部楼层
回复 支持 反对

使用道具 举报

237

主题

286

帖子

1675

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1675
 楼主| 发表于 2015-6-8 22:50:01 | 显示全部楼层
WAN: Wide Area Network缩写--广域网;LAN: Local Area Network缩写--局域网, WLAN: wireless LAN---无线局域网
br-lan=lan网桥, 将WLAN和LAN(交换机)绑定为一个虚拟接口
eth0=lan接口(注意 是路由器上的LAN RJ45口)
eth1=wan接口(注解同上)
wlan0=无线端口
回复 支持 反对

使用道具 举报

237

主题

286

帖子

1675

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1675
 楼主| 发表于 2015-6-8 22:58:48 | 显示全部楼层
回复 支持 反对

使用道具 举报

237

主题

286

帖子

1675

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1675
 楼主| 发表于 2015-6-9 15:03:58 | 显示全部楼层
Step 3 : 让OpenWRT能连接WIFI

上一段说了一些完全不知道对不对的理论,现在开始实际操作,首先编辑/etc/config下的wireless文件,命令是

vi /etc/config/wireless

在“#option disabled 1”这一行下面加入OpenWRT连接WIFI的配置,内容如下:

config wifi-iface 'wlan0'                 
        option device   'radio0'         
        option network  'wan'            
        option mode     'sta'            
        option ssid     要连接到的WIFI名称  
        option encryption 'psk2'        
        option key      那个WIFI的连接密码是多少

然后按Esc退到普通模式,输入“:wq”保存并退出。
Step 4 : 让OpenWRT对WIFI进行接力

接着编辑/etc/config下的network文件,命令是

vi /etc/config/network

好啦这里要注意,首先将原本的“option ipaddr '192.168.1.1'”改为“option ipaddr '192.168.2.1'”,其次在文件的最末尾加上以下内容:

config interface 'wan'
        option proto 'dhcp'
        option ifname 'wlan0'

接着保存并退出。
Step 5 : 注意事项及结果验证

这个时候要注意了!你以后要连接到OpenWRT不再是输入“ssh root@192.168.1.1”,而是输入“ssh root@192.168.2.1”,一定要记住啦!

最后输入以下命令重启OpenWRT:

reboot && exit
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|四博智联 Inc. ( 粤ICP备15034758号-1

GMT+8, 2020-12-3 22:17 , Processed in 0.050370 second(s), 22 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表